Back to overview
Maintenance
Server Update
Mar 14, 2026 at 03:30am UTC
–
Mar 14, 2026 at 04:38am UTC
Affected services
CDN
Projects
Syd02
Resolved
Mar 14, 2026 at 04:38am UTC
All services has been updated and are now online!
Affected services
Created
Mar 14, 2026 at 03:30am UTC
We will be updating all services on Syd02.
Affected services