Back to overview
Degraded
Increased ping
Oct 13 at 04:30pm AEDT
Affected services
Minecraft Network
Resolved
Oct 23 at 08:44pm AEDT
We’ve successfully fixed the ping-related issues and the Asia servers are now working. Everything should be running smoothly.
Affected services
Updated
Oct 17 at 08:19pm AEDT
We have identified that our data center has been relocated from Sydney1 to Singapore1, which is contributing to the increased latency. We are aware of the issue and are actively working on a fix.
Affected services
Created
Oct 13 at 04:30pm AEDT
We have received reports of increased ping and are currently investigating the cause. We will provide updates as soon as we have more information.
Affected services