Back to overview
Downtime

CDN is down!

Oct 17 at 08:34am AEDT
Affected services
CDN

Resolved
Oct 17 at 08:25pm AEDT

We have started all our servers back up again.

Created
Oct 17 at 08:34am AEDT

We believe Windows did another update but we can not confirm, we are currently trying to fix the issue.