Back to overview
Degraded

TPS Drops

Oct 11 at 01:15pm AEDT
Affected services
Minecraft Network
Dashboard

Resolved
Oct 16 at 06:35pm AEDT

We have found the issue and fixed it! Server should be running at full speed!

Updated
Oct 16 at 09:32am AEDT

We have fixed many issues affecting TPS, but we’ve noticed that it still drops whenever someone teleports. We’re currently working on a patch to resolve this.

Created
Oct 11 at 01:15pm AEDT

The server is currently experiencing high latency and low TPS. We are aware of the issue and are investigating the cause. Thank you for your patience.