Back to overview
Downtime

Unexpected shutdown occoured

Aug 01 at 04:18pm AEST
Affected services
Website
Minecraft Network

Resolved
Aug 01 at 04:24pm AEST

Started.

Updated
Aug 01 at 04:22pm AEST

Starting servers.

Created
Aug 01 at 04:18pm AEST

Server shutdown.