Back to overview
Downtime

Unexpected Shutdown

Jul 21, 2025 at 10:28am UTC

Resolved
Jul 21, 2025 at 11:03am UTC

Server online.

Updated
Jul 21, 2025 at 11:00am UTC

Server restarted.

Created
Jul 21, 2025 at 10:28am UTC

Server shutdown.