Back to overview
Downtime
Server Unexpected Restart
Jul 19, 2025 at 01:10pm UTC
Resolved
Jul 19, 2025 at 01:48pm UTC
Back online.
Affected services
Updated
Jul 19, 2025 at 01:45pm UTC
Servers starting back up.
Affected services
Created
Jul 19, 2025 at 01:10pm UTC
Some servers has unexpectedly start to restart.
Affected services